Posted on

Gigaset flashing base

Gigaset flashing base:

Gigaset flashing base

My Gigaset flashing “base”, when I return the handset (HS) to the cradle it doesn’t beep (as though it’s not powered up) and the phone continues to flash “base”. I’ve tried to re-register automatically (leave HS on base for 5 mins) and manually through the HS menu but although the HS does seem to try register to the base station, the pager button on the base is not doing anything. Any advice?

Try…unplug the battery pack, set the phone down for 25 minutes and then plug the pack back in. Phone should work again after that.

Try…make sure the connections on the phone are touching the base correctly

Try…To register your handset to that base station. Put the base station in registration mode at the same time you put the handset in registration mode. Go to settings using your menu key, select “register HS”. OK when it asks you to register. If it asks for the pin, use 4 zeros(0000) (factory pin) and push OK. The handset should flash “registering”. Then on the base press the page/reg key down for about 20-30 seconds. The handset will now look for the handset and vise versa. If it shows “invalid pin” then you need to use the pin you changed it to or reset your pin on your base. If the handset times out and never registers, you may have a faulty base.

Try…check the base station power supply. Check if the phone shows charging when replaced on the charging tray. If not charging replace the power supply

Try…if the phone shows charging then the base station is faulty. Replace the base station or if this is not sold then purchase new handset and base and re-register the handsets. To replace your handset have a look at the latest range of cordless phones for sale.

If you still need help for further support please call us in South Africa on 011 206 2900